Redcore Linux Project Forum

Unfortunately no one can be told what Redcore Linux is - you have to see it for yourself.

You are not logged in.

#1 2022-02-11 19:56:44

crismblog
Member
Registered: 2021-12-06
Posts: 3

Uninstall fontforge not work

I want to uninstall fontforge from the terminal or gui and it doesn't work.

[root@redcore /home/cris # sisyphus uninstall media-gfx/fontforge
root@redcore /home/cris # emerge --ask --verbose --depclean media-gfx/fontforge

Calculating dependencies                   ... done!
  media-gfx/fontforge-20201107 pulled in by:
    media-fonts/arphicfonts-0.2.20080216.1-r2 requires media-gfx/fontforge

>>> No packages selected for removal by depclean
Packages installed:   1157
Packages in world:    120
Packages in system:   44
Required packages:    1157
Number removed:       0
root@redcore /home/cris # emerge --ask --verbose --depclean media-gfx/fontforge media-fonts/arphicfonts

Calculating dependencies                     ... done!
  media-fonts/arphicfonts-0.2.20080216.1-r2 pulled in by:
    app-text/ghostscript-gpl-9.55.0-r1 requires media-fonts/arphicfonts

  media-gfx/fontforge-20201107 pulled in by:
    media-fonts/arphicfonts-0.2.20080216.1-r2 requires media-gfx/fontforge

>>> No packages selected for removal by depclean
Packages installed:   1157
Packages in world:    120
Packages in system:   44
Required packages:    1157
Number removed:       0
root@redcore /home/cris #]

Offline

#2 2022-04-21 21:49:54

V3n3RiX
Administrator
Registered: 2021-11-04
Posts: 17

Re: Uninstall fontforge not work

korhal ~ # equery depends fontforge
* These packages depend on fontforge:
app-office/libreoffice-7.3.2.2-r1 (media-gfx/fontforge)
media-fonts/arphicfonts-0.2.20080216.1-r2 (media-gfx/fontforge)
media-fonts/dejavu-2.37 (fontforge ? >=media-gfx/fontforge-20080429)
media-fonts/liberation-fonts-2.1.3 (media-gfx/fontforge)

korhal ~ # equery depends arphicfonts
* These packages depend on arphicfonts:
app-text/ghostscript-gpl-9.55.0-r1 (l10n_zh-CN ? media-fonts/arphicfonts)
                                   (l10n_zh-TW ? media-fonts/arphicfonts)

korhal ~ # equery depends ghostscript-gpl
* These packages depend on ghostscript-gpl:
app-text/gocr-0.52 (doc ? app-text/ghostscript-gpl)
app-text/libspectre-0.2.9 (>=app-text/ghostscript-gpl-9.24)
app-text/qpdf-10.6.3 (test ? app-text/ghostscript-gpl[tiff(+)])
dev-lang/nasm-2.15.05 (doc ? app-text/ghostscript-gpl)
dev-util/ragel-7.0.4-r1 (app-text/ghostscript-gpl)
media-gfx/fbida-2.14-r3 (ghostscript ? app-text/ghostscript-gpl)
media-gfx/gimp-2.10.30 (postscript ? app-text/ghostscript-gpl)
media-gfx/graphviz-2.50.0 (postscript ? app-text/ghostscript-gpl)
                          (doc ? app-text/ghostscript-gpl)
media-gfx/imagemagick-7.1.0.20-r1 (postscript ? app-text/ghostscript-gpl)
media-gfx/inkscape-1.1.2 (postscript ? app-text/ghostscript-gpl)
media-libs/netpbm-10.86.30 (postscript ? app-text/ghostscript-gpl)
net-print/cups-filters-1.28.15 (postscript ? >=app-text/ghostscript-gpl-9.09[cups])
net-print/hplip-3.22.2 (app-text/ghostscript-gpl)

As you can see, the dependency chain gets really long, really fast. You can remove it with --force option if you really want to, but it will get pulled back in to fix the dependency chain.

Offline

Board footer

Powered by FluxBB