Redcore Linux Project Forum

Unfortunately, no one can be told what Redcore Linux is. You have to see it for yourself!

You are not logged in.

#1 2023-05-25 16:23:45

Registered: 2023-05-25
Posts: 3

Wlroots v0.16 masked, why?

Hello there,

I'm not very familiar with gentoo, but managed to use it and its many ebuilds thanks to your fantastic distro!

But after trying to upgrade today, I was met with the following error:

Local copy of remote index is up-to-date and will be used.
!!! FEATURES=fakeroot is enabled, but the fakeroot binary is not installed.

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by gui-wm/hyprland-0.25.0::gentoo[X]
# required by @selected
# required by @world (argument)
>=gui-libs/wlroots-0.15.1-r1 x11-backend

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy ">=gui-libs/wlroots-0.16.0[X?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- gui-libs/wlroots-9999::gentoo (masked by: missing keyword)
- gui-libs/wlroots-0.16.2::gentoo (masked by: package.mask)

(dependency required by "gui-wm/hyprland-0.25.0::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Cannot proceed!

Apply the above changes to your portage configuration files and try again

I wasn't aware of what masking was or how it worked, but quickly realized that this was intentional: … de0446dafa

So the Question is: Should i just wait until the package has been tested and will be unmasked? (it will be unmasked right?) And will the change be applied using sisyphus update? (since sisyphus upgrade is being blocked because of this).

PS: Take your time, maintaining a distro must be hard.

Last edited by leothetechguy (2023-05-25 16:30:53)


#2 2023-05-25 17:01:04

Registered: 2021-11-04
Posts: 58

Re: Wlroots v0.16 masked, why?

Honestly, I want to unmask wlroots v0.16 today if possible, however, Qtile strictly depends on wlroots v0.15, as an updated version hasn't been released yet. There is a pull request :, but hasn't been merged yet.

In order to keep everything in the repo conflict free, I masked wlroots v0.16 for the time being. As soon as Qtile gains wlroots v0.16 compatibility, I will remove the mask.

And that's also the reason why hyprland is not packaged and provided as a binary yet. With Qtile wanting wlroots v0.15 and hyprland wanting wlroots v0.16, I had to make a choice, I choose to keep Qtile since I plan to release a Qtile iso image in the future.

That being said, if you don't have Qtile installed, or you don't intend to install it, you can comment the wlroots mask in /etc/portage/package.mask/00-gui-libs.package.mask and the pywlroots mask in /etc/portage/package.mask/00-dev-python.package.mask. In addition you must add gui-libs/wlroots x11-backend line into /etc/sisyphus/sisyphus.package.use.

These changes are what sisyphus asks you to do, in able to be able to proceed and update hyprland. Though, be aware, those changes may be overridden at any time in the future.

Or, you can just uninstall hyprland and the conflicts will go away and sisyphus will be able to update the rest of the system. Though, if you want to reinstall it afterwards, you need to do the changes mentioned above to be able to do that.


#3 2023-05-25 17:23:02

Registered: 2021-11-04
Posts: 58

Re: Wlroots v0.16 masked, why?

You can ignore my previous post, but I'll keep it around as general knowledge.

I changed some configuration files, so the conflict will go away by itself next time when you try to update. It will take a while (a few hours) to propagate, but keep trying until sisyphus succeeds and offers you to upgrade the system without any messages such as in your first post. The solution I choose is to disable wayland support for Qtile for the time being, until a wlroots v0.16 compatible version will be released. This way Qtile no longer depends on wlroots and wlroots doesn't need to be held back.


Board footer

Powered by FluxBB